SharePoint Experts, Information Architects, Expert Witness

SICG provides a broad array of business and technology consulting from architecture to design to deployment of global systems with a focus on surfacing data in the enterprise. We focus on the "How", not just the possible. Contact me direct: david_sterling@sterling-consulting.com or call 704-873-8846 x704.

Search This Blog

Wednesday, February 1, 2017

SharePoint 2013 Prerequisites - unable to install Application Server Role, Web Server (IIS) Role

While I've posted before on this, the other solutions I've used didn't work. I resorted to my own version of the installation process when you get this error.

Open up PowerShell (using 'Run as administrator') and enter the following as 'groups' (run one command at a time):

Set-ExecutionPolicy Unrestricted

Enter Y when prompted, next:

Import-Module ServerManager

Next:

Add-WindowsFeature NET-Framework-45-Core,NET-Framework-45-ASPNET,Web-Net-Ext45,Web-Asp-Net45,Web-Includes,NET-WCF-HTTP-Activation45,NET-WCF-TCP-Activation45,NET-WCF-Pipe-Activation45

This should indicate success - next:

Add-WindowsFeature Net-Framework-Features,Web-Server,Web-WebServer,Web-Common-Http,Web-Static-Content,Web-Default-Doc,Web-Dir-Browsing,Web-Http-Errors,Web-App-Dev,Web-Asp-Net,Web-Net-Ext,Web-ISAPI-Ext,Web-ISAPI-Filter,Web-Health,Web-Http-Logging,Web-Log-Libraries,Web-Request-Monitor,Web-Http-Tracing,Web-Security,Web-Basic-Auth,Web-Windows-Auth,Web-Filtering,Web-Digest-Auth,Web-Performance,Web-Stat-Compression,Web-Dyn-Compression,Web-Mgmt-Tools,Web-Mgmt-Console,Web-Mgmt-Compat,Web-Metabase,Application-Server,AS-Web-Support,AS-TCP-Port-Sharing,AS-WAS-Support, AS-HTTP-Activation,AS-TCP-Activation,AS-Named-Pipes,AS-Net-Framework,WAS,WAS-Process-Model,WAS-NET-Environment,WAS-Config-APIs,Web-Lgcy-Scripting,Windows-Identity-Foundation,Server-Media-Foundation,Xps-Viewer

This should also indicate success (it may also indicate No Changes Needed).

For best results, run the Prerequisites UI again just to make sure.

FOLLOW UP: I had one server that just would not get corrected; it still indicated that the Web Server role had a configuration error.

In this case, I decided to try loading up a W2012 server and not apply the Windows Update but install SharePoint first - SAME PROBLEM.

Fix: I tried loading the installation that has SP1 already - running the Prerequisites alone (from the install disk using 'Run as administrator') it worked!

Post a Comment