SharePoint Experts, Information Architects, Expert Witness

We provide consulting in a broad array of business and technology from architecture to design to deployment of global systems with a focus on surfacing data in the enterprise. Specialists in Microsoft, we are a premier provider of SharePoint Expertise (including 2016 and Office 365). We also provide Expert Witness/Legal Expert in eDiscovery, source discovery, patent infringement, piracy and more! We also have established SICG DLDS s.a. - our counterpart in Costa Rica that specializes in water systems (http://www.crwatersolutions.com) - Contact me direct: david_sterling@sterling-consulting.com or call 704-873-8846 x704.

Search This Blog

Tuesday, June 30, 2015

SharePoint 2013 Apps Won't Load

While I've not come across this before when setting up the Apps, specifically the DNS either as a standalone domain or just using a CName record, I did encounter a problem on a local development environment - not sure if this is a 'fix' or simply something as a work around.

In effect, the DNS was setup with a domain of SP13TDevApps.com (and tested on the AD/DNS system) but when trying to add an App it returned "The page can't be displayed" even though the nasty URL (thanks MS) is indeed correct:


Everything was checked from both the DNS server and the server hosting SharePoint but nothing seemed wrong:


As a last thought, a ping on the server itself revealed that it was (as is generally normal) returning the IPV6 address:


Just as a guess, I tried adding SharePoint Server name and IPV4 address to the Hosts file on the server:


And viola:


Again, this is just the environment I was in and it is development as well so take the above with a grain of salt - however, it's a pretty painless thing to try if you come across this issue but remember, if it doesn't work, remove whatever you changed and check your settings again.